The Twine forums are now archived. If you need help, please visit

Twine can't find any WIFI networks on set up

Multiple networks in area. N, G mixed, I even set up an old router to add a B-only network. Tried set up via IE9, Firefox and iPad. No joy. There used to be a support question from others with this issue (I have it bookmarked) but it seems to have disappeared. Help Please.

Best Answer

  • 17 Comments sorted by Votes Date Added
  • Hey Jeff,

    I had a similar issue and found that changing the channel on the router helped. The manual of my router identified several channels as 2.4 GHz, changing to one of these enabled TWINE to see the network straight away.


  • I had to use an IPad since my PC is connected to a LAN. Worked great from the IPad.

    Required a 2 step process.
  • First thing I can suggest Jeff, is to use fresh batteries. The 3A's in my delivery were not strong enough. Once I replaced them, my laptop could see Twine.
  • Thank you Gene and Don. I tried setup via an iPad and encountered the same behavior as with the browsers on my laptop. I also tried replacing the batteries with no change in behavior. I'll try again tonight in case my replacements were also weak.
  • Also Don, as clarification... My laptop can see the Twine's wireless network fine during setup... It's just that then, the Twine cannot see any of the standard WIFI networks in my home (mine nor my neighbors). When set-up asks me to "choose a WiFi network", the dropdown list is empty.
  • Jeff -

    How far do you get in the initial setup? And is your (or your neighbors) router sending an SSID?
    One thought.... Try shutting down any encryption you have running for a short time, and see if Twine can observe your router.

    Regards - Don
  • Hi again, finally got a chance to mess with this again. To answer your questions:
    1. I get to the point in set up where I am asked to choose a wireless network for twine to connect to. I am able to make my computer or iPad join Twine's network. But then when Twine looks for local wifi. It can find none and the selection list is empty.
    2. Yes all of the networks are broadcasting an SSID. I have a 5ghz mixed, a 2.4hgz mixed and a 2.4ghz b-only. There are usually 2 others belonging to neighbors that computers/iPads can also find. Twine can see none of them.
    3. I tried turning off wifi security and running setup again. It still can't see any networks.
    My schedule makes it difficult to t.shoot during their open hours. I really want this to work. I guess I need to try to email them for direct support.
    If you guys have any other thoughts I'd appreciate them.
  • All this tweaking of otherwise standard WiFi setups, just so Twine can connect, suggests significant weakness in Twine's firmware / hardware. My own Twine connects easily maybe 50 percent of the time. If I leave it unattended (with USB power connected) and look later, I find it's flashing the "I'm not connected" message. I've pretty much given up on the Twine for now (re-boxed it) and will wait for a firmware update before I waste more time on it.
  • Likewise. I had to remove the batteries as it was causing my network to drop out for all the other devices in my house. In addition, I have not been able to get any notifications from sensor events. Dashboard status seems fine though and shows correct sensor states.

    In the end I had to kill it and I re-boxed mine as well. Hopefully, there will be a firmware solution for these wifi issues otherwise it's basically bricked.
  • Fresh batteries helped my cause and correcting an operator error...

    My router is an Apple Time Capsule, it runs flawlessly compared to my past routers (Dlink, Linksys, etc.) but when it came to setting up my twine it was a real challenge. In the end it was an operator error on my part. Previously to adding my twine I controlled access to the router using the old school method - via mac addresses. Once I enabled wpa/wpa2 personal to support my new twine I assumed (dangerous word) the router would disable mac address enabled limited access. Unfortunately that's not the case. Once I disabled the mac address access feature on my router my twine connected no problem.

    And now I'm happily getting twine enabled email messages...

    Does any know where I can get an infrared sensor for my twine?
  • Thank You Eric !!! The channel change did the trick! That really needs to be in the knowledge base somewhere/somehow!
  • Recently, for other reasons, I changed my router from my old belkin to a new Billion 7800 DVOX. Once setup and I configured all the Macs, iPods, iPhones, iPads, AppleTVs, etc in the house (the overheads of having three teenagers in the house in the modern age) I thought I would try the Twine again and freed it from the box where I left it last Dec. 

    This time it seemed to behave no worries and the network so far seems to be stable. With the old router it became flakey when the Twine was connected.

    So far so good. 
  • James,

    What do you need the IR sensor to do; just an open/close when an IR beam is broken?

  • Hi all,

    I was having the same problem as the others above. No wifi networks were discovered in step 3. There are at least a dozen in the area per my other devices but Twine couldn't find any.

    I did everything in this thread and none of it worked: Changed channels, set router to B only, took off security, blah. I have a dd-wrt flashed router so plenty of settings to fiddle with, but i really felt like it was something with the device because it couldn't find ANY wifi network, not just mine.

    But then I came across these instructions.

    Which worked perfectly. In the admin dashboard, I saw a long list of neighborhood networks, as well as my own. I selected mine, and was off to the races.

    Just passing on my solution.
  • One additional note - the steps in the link above require that you send information to supermechanical for themn to manually associate the Twine with your account. You can actually work around that and do it right away by following these steps:

    1. Proceed to step 3 normally. 
    2. When no networks are found, but gibberish in for the password and click done
    3. You will go to step 4, but of course your Twine is not found. There will be a couple attempts to connect by the server but it will give a help page when everything fails. KEEP THIS PAGE OPEN AND DON'T CLICK ON ANYTHING.
    4. Follow the steps in the link above to add the wifi network manually. In my case, it was actually listed under 'select a network' section, so i didn't need to create it.
    5. When that is done, reconnect to your local wifi and go back to the page you kept open in step 3 above.
    6. Click refresh, and the Twine will associate with your account. Presto.
  • Weird -- no networks showed up in step 3 on March 8. But on March 9, just as I was about to try Craig's trick, networks showed up in step 3 as expected.
Sign In or Register to comment.