The Twine forums are now archived. If you need help, please visit

Twine isn't updating dashboard & won't go into setup mode

My twine "Hasn't been heard from.", but will not go into the setup mode. I have removed the batteries for >10 seconds; I have tried USB power instead of batteries. The LED pulses a few times, then goes out. Flipping the twine over causes the LED to flash once (on then off) and then nothing.

Clicking the network setup button in my account page just causes a 500 error in my javascript console.

What do I do now?


  • 30 Comments sorted by Votes Date Added
  • Same problem. I'm not able to go into setup mode. Any suggestions?
  • Paul, I'm having the same issue.  It happened for me a few times before which coincided with the times listed when others had this issue, and then just started working.  All five of mine stopped showing up (reporting) in the dashboard around the same time as yours. I've confirmed: they have brand new full alkalines; they connect to my wifi AP; when I turn them over, for a brief time I can ping them (while they are trying to connect to aka aka and also that I see the ports and connections in my Internet facing router to .  The same thing happened before; all of the sudden, it started working.  I don't think there's anything we can do to remedy it, but that we have to wait for Supermechanical to fix whatever transient issue occurs/is occurring.  That's just my two cents.
  • My twine has just starting doing the same thing tonight as well.
  • Same here as of this morning.
  • I'm back to no updates (for three days) and I'm not sure why. I can access the rules and save changes, or so it seems, but I can't seem to get an update of temperature or any other sensor.
  • Same problem here, no updates for several days...
  • And now it's gone into "hasn't been heard from" mode. Since I have it monitoring a house about 150 miles away it's a bit difficult to pull the plug and see if I can reboot it or otherwise troubleshoot.
  • Same issue here.  Can't go onto setup mode.  Can't get into network.  Happened after I changed batteries.
  • Happend here today too. Both twines were working fine yesterday. Since this morning both of my twines are in ""hasn't been heard from" mode. Just a single pulse of the LED.

    Anyone with the same problem today?
  • ...and now it appears is down? Or is it just me?
  • ...and now it's back, so... thank you!
  • Yeah, so this was either a issue, or a problem with the network I was connected to at the time (I was traveling).

    Apparently my twine was able to connect to the wifi network, but not communicate with

    The fact that this prevented me from putting my twine into setup mode bothers me. 
  • Having the same issue.. This thread says it has been answered, but it is not obvious to me how it was answered.
  • having the same issue now. can't get into setup mode.
  • When I flip the device over, I get a SINGLE pulse of the LED.  It won't go into setup mode.  HELP!!!!!
  • Despite what it says on the header, this Is NOT answered.
  • Same thing here.  Works intermittently but single pulse of light and no setup mode when turning over.
  • Having the same issue. Did anybody manage to resolve this?
  • Same problem here, as well.  Has anyone put in a ticket?
  • My twine worked for months just fine, but now there's no TWINE network when it's flipped over. The LED is solid but it's otherwise bricked.
  • Same issue here. Twine was working fine but now hasn't been heard from in 24hrs. When I flip it over the light comes on for maybe 5 secs then goes out. The twine connects to my wifi network, I can even ping it when it's upside down but it won't "phone home". Any advice?
  • My Twine has also hasn't been heard from. It is working, I can see it is logged in in my network. Is the server down?
  • Thanks Siobhan, guess I'll just sit tight and hope Supermechanical fixes this quickly. Maybe the AWS EC2 instance our twines connect to has crashed?
    M.G. see Siobhan's answer higher up in this thread.
  • The Twine server appears to have been having issues around the 21st of July (for me anyway), Aug 2-3 for those who mentioned it above (also me), and now that Paul, M.G. and myself are suddenly having the same issues, it appears that to be the case again.

    Still down for me.

    I wish Supermechanical would comment on this, and let us know they are aware of yet another outage and what the ETA is for bringing it back up.

  • same problem here since 4 days
  • and suddenly back again ...
  • Everyone, apologies for the downtime and for not communicating it better.

    There was a problem affecting some users this weekend, much like previous outages, where first, connections from Twines were being dropped by the server, and eventually, the site crashed. We didn't catch it right away because it was a gradual degradation that dropped only some Twines, and worse, this time it didn't trigger our watchdog process that notifies us as soon as something's wrong. 

    To prevent this from happening again, we're 1) addressing the degradation issue in code and server resources, 2) changing to a new external watchdog service and 3) adding more points to monitor failures internally and externally, so that if something does go wrong, our watchdog processes can correct the problem and/or make us aware of it immediately.

    Everything should be running as of this morning - email us at if you're still seeing problems and we'll get on the case. I'm sorry for the trouble, and we'll do better in the future. 

  • Thanks, John - that's very helpful information.  I'm glad to hear things are looking up and those changes sound really promising.  My Twines are indeed showing up again.
Sign In or Register to comment.