The Twine forums are now archived. If you need help, please visit

Twine Update 2.0: Battery life and more

Remember when we mentioned we were undertaking a major rework of Twine's radio firmware to improve battery life? It’s here, and it brought some friends! You can read about everything that is included in our blog (might want to have a snack handy, it's long).
You can start this update from your Account page. Under "Your Twines" you'll see a link to "Upgrade to 2.0 firmware" — tap on that and follow the instructions. The website has been updated as well so make sure you clear your browser’s cache too. Read on to understand all the implications.

Battery life
With the radio update, Twine will be able to run 2 months or more on 2 AAA batteries, depending on usage. Of course, if you don’t want to rely on batteries, that's why we gave Twine a micro USB port — you can use it to plug into the wall.
The update comes with a change that makes this extended life possible: your Twine’s dashboard will update every 20 minutes. This will not affect how you receive notifications — when your rules are triggered, Twine will notify you right away, same as before.  If you’d like to keep your Twine updating every minute, you can ignore the update — you just won't get the battery life improvement.
Sharing the dashboard
You can now share your Twine’s dashboard, or just one sensor. Only the people you share the key with will be able to see the data. Don’t want to share anymore? Uncheck the box, and Twine’s data is private again.
Networking improvements and more
What else is included? Support for hidden networks (with the 2.0 radio update). Networking improvements for even better reliability. More accurate timekeeping. Quicker triggering of multiple actions. Celsius reporting in rules. And lots of smaller tweaks to make things better all over the place.
Last but not least, you'll notice that we've exchanged the formerly unwieldy address of Twine's web app for the svelte new - update your bookmarks and homescreen icons accordingly.



  • 44 Comments sorted by Votes Date Added
  • So anyone working on this anymore ?
  • Just tried this, and before I could update to 2.0 it said I had to update my firmware. I clicked for it to go ahead and got a "compile error" in my browser. Now my twine won't connect to my network.
    It still works in access point mode, but when I turn it back over, the light just blinks and it never connects.
    What are the consequences of "compile error". Has it bricked my twine?
    BTW, I'm using Chrome on a Mac.
  • We got your email and responded there as well, but for posterity's sake (and in case others are curious), compile errors won't brick your Twine. It's a symptom of rules not being able to save properly.
  • Thanks, Christina.

    Also for posterity's sake: Thanks to some truly excellent and responsive support, my Twine is fully functional, and back online. The fix was merely to retry setup - it took several retries, and several hours (elapsed time - I wasn't retrying for several hours!), and it all worked perfectly. The true fix was just a bit of patience.
  • Setup was a NIGHTMARE for me.  Somehow, evidently because I wasn't wishing hard enough for the first two hours, I eventually got through it.  Literally...there was nothing logical that made it finally work.

    If the solution to "Compile error" is to go back through setup, well, GREAT.

    Update:  just tried it, and JUST like the last time, I do EVERYTHING the site suggests, and after connecting to the TWINE on in my wifi menu, it stares at me blindly, with the message "Waiting for you."
  • FWIW, my twine has been upside down and updating 'Working...' with the spinner going for over 10 minutes w/ the LED blinking. I'm not clear at HOW long this should take, but even still the page that says 'This upgrade will take 30-60 seconds — don't interrupt it! Before you begin, make sure your Twine has a good Wi-Fi signal and fresh batteries (or external power).' should be updated to reflect this. After how long should I start trying something else?

    Edit: it seems that the update process caused my TimeCapsule/Airport to crash. Once everything came back up, I pulled the twine batteries, went back into setup, respecified my network SSID, then everything started updating.
  • Mark and Alan, it looks like your Twines have the update now. Mark, if you get stuck during set up again, try following these steps.

    Alan, thanks for letting us know, we did a lot of testing on Airports, and never had any crashes! In general, if things are taking longer than expected/generally not going as expected, shoot as an email before you get frustrated.

  • Also getting the "Compile Error" using either Safari 5 or Chrome for Mac. Did one round of Setup with no difference. Using 1.3.0 firmware now and really not feeling very confident about this.
  • So I got to the "Update your radio" part (note: the last update was Nov-5-2012, not 2013 :-) and clicked the "I'm Flipped" button. It spun for a while and then went back to "You need to do an update and, by the way, Compile Error" screen. Now the Twine won't connect to my Airport Express any longer. *sigh*

  • I got a compile error. I removed my batteries, and unplugged the power. I went to re- set up my twine from the beginning, and now my twine wont connect to my network. During the set up, the web site sais everything was successful. Waited the 70 seconds.... And then nothing. I tried resetting about 6 times. I am very frustrated with this.
  • Same thing here, Barry. It looks like I now have a turquoise brick.
  • Mine is also completely worthless after attempting the update.  I've tried re-setting it up with no luck. When it gets to the last step, it will not connect to the wifi network, but the light just stays flickering.  I guess I no longer have to worry about it, since it's a brick.
  • I'm stuck at the dreaded "waiting for you" stage after hitting "compile error" and just about every other error mentioned here.  Twine was upside down at one point with the white light on for 10 minutes or more.  Still no connection.  It started blinking (slow pulse) at that point  I've tried pulling the batteries multiple times(and waiting more than 10 seconds), but I'm still not getting the connection.  Now it's pulsing again.

    How do I get this back online?
  • I can't see the "update" button under my account - I tried to upgrade but it failed, so I went through the setup again. My twine is connected, but now the option to upgrade is gone.

    Just tried to save my rules - Compile Error.

    Tried setup 4 times - it says it's worked, but it doesn't connect to the network.

  • Exactly the same problems than former "twiners".
    "compile error", new setup, TWINE not connecting, but I can access it to configure it, etc.
    I have done the setup several times. Still no connection.
    I will try again after work.

  • In addition to my post above, I have cleared my cache, and rebooted my router. It still seems to be a turquoise brick.
  • My issue has been resolved. Thank you
  • Have been through setup a dozen times.  Twine is stuck with the light on as if it is still in setup mode.  Can remove batteries and complete setup again, but when you flip it over after setup is complete it is still in setup mode.  "Trouble connecting to network page" is all I get in the browser after it tries to search for newly "setup" twine.
  • There was a problem with compiling rules (and the update) last night, was fixed this morning. If you had the issue and now your Twine's not working properly, send an email to us (, and we'll get it working again.
  • Mine now compiles and is connected (thanks), but I still can't see the "Update" link under my Twines, and the dashboard is the old one.
  • The dashboard in the email is actually a screen shot of the app called Panic Status Board (Twine - please comment if I am wrong)

    I had an issue with updating too but Twine Support fixed it - lesson is to not get frustrated and to use their support. It works ;)

    I am looking forward to doing more integration with IFTTT - I would love a Twine Channel to make it more direct.

  • Finally figured out the image was of Panic Status Board - I had been looking for a new dashboard after updating. Duh.
    First update said it failed. I redid and it said it succeeded. Where can I find what version I have so I know it succeeded?
    Also,  I do not see a "share" button in my Twine's rules page, so that I can add Twine status to Panic Status Board, not the whole dashboard.

  • Thanks, Christina, for providing the solution.  My Twine is now "online" and working. 

    I quote her message as it can be useful to other "twiners":

    It looks like your Twine saved the new radio update successfully, but not the new ARM code. Unfortunately, the new radio firmware doesn't play nicely with the old ARM. It looks like you're getting a compile error because there's isn't enough space on your Twine to save the new software (it's slightly larger than the old code). If you'll delete a couple rules and resave your rules, then power cycle your Twine, it should bring it back to life."

  • Got mine working after I deleted some of my rules.
  • Dan, you can find out what firmware your Twine is using by hovering your cursor over your Twine's name on the dashboard. Current is May 24 and 2.0.0. Looks like you've got the latest.
    The share button is on the top right of the dashboard, where it says "rules" if you're on the homepage.
  • I have 4 Twines on my network, or at least I did. Now I only have 3 since I tried to update one of them to 2.0.  All it does is a slow blink after it tried to do the update.  I've deleted rules, I've tried redoing the setup, and over and over.  I've sent an email requesting help as well.
  • Jim, I responded to your email in help on 6/7. Maybe it got caught in a spam filter? I just resent your Twine the update. Power cycling it now should do the trick. Email us again if it didn't.
  • Thank you, I'll try updating the rest of my Twines
  • I too had lots of problems with updating and getting back on the network. Friendly help from Twine, but no success. What finally worked: I switched my wifi to B-only, and then the update took and I could get the twine online. Worked fine after I switch the wifi back to mixed. 

  • How does sharing work?

    Is there a link I can send to someone along with the access key?

Sign In or Register to comment.